QuickBooks Learn & Support Home
  • QuickBooks, United States

System requirements for QuickBooks 2008 and QuickBooks Enterprise Solutions 8.0

Click the links below to see information for different operating systems, versions of QuickBooks, and installation options.

Note: QuickBooks has not been tested with Internet Explorer 9. In some cases, it may be necessary to revert to Internet Explorer 8 to ensure the best possible performance with QuickBooks.

Note: QuickBooks will work with systems running RAID (Redundant Array of Inexpensive Disks) but it is not recommended due to performance issues resulting in QuickBooks operating slowly.


Was this article helpful? Yes No
Do you still have a question?

Ask your question to the community. Most questions get a response in about a day.

Post your question to the community